Elevated error rates with Dashboard and API due to AWS us-east-1 outage
Resolved·Degraded performance

PlanetScale is continuing to monitor the condition of AWS us-east-1. At this point we do not see any further impact, and have re-enabled database and branch creation in the region.

Mon, Oct 20, 2025, 08:48 PM
(1 week ago)
·
Affected components
Database Operations
Dashboard and API Requests
Updates

Resolved

PlanetScale is continuing to monitor the condition of AWS us-east-1. At this point we do not see any further impact, and have re-enabled database and branch creation in the region.

Mon, Oct 20, 2025, 08:48 PM

Monitoring

PlanetScale is continuing to monitor the condition of AWS us-east-1. We have seen networking conditions and compute availability in us-east-1 continue to improve. Out of caution, database and branch creation continues to be disabled in AWS us-east-1.

Mon, Oct 20, 2025, 08:08 PM(39 minutes earlier)

Monitoring

PlanetScale is continuing to monitor the condition of AWS us-east-1. At this time database and branch creation continues to be disabled, and we are seeing some degraded network performance between components inside of us-east-1 and inbound connectivity into the region.

Mon, Oct 20, 2025, 06:56 PM(1 hour earlier)

Monitoring

PlanetScale is continuing to monitor the condition of AWS us-east-1. At this time database and branch creation continues to be disabled, and connectivity may be disrupted into the AWS region.

Mon, Oct 20, 2025, 05:39 PM(1 hour earlier)

Monitoring

PlanetScale is seeing degraded network connectivity across AWS us-east-1 components reaching both MySQL and PostgreSQL databases. We are currently monitoring the situation and will continue to update the status page.

Mon, Oct 20, 2025, 05:06 PM(32 minutes earlier)

Monitoring

Database creation in AWS us-east-1 is currently disabled.

Mon, Oct 20, 2025, 03:59 PM(1 hour earlier)

Resolved

Dashboard and API are back fully operational

Mon, Oct 20, 2025, 09:36 AM(6 hours earlier)

Identified

There is a AWS us-east-1 outage. Existing databases are unaffected - new databases cannot be created.

Mon, Oct 20, 2025, 07:36 AM(2 hours earlier)

Investigating

SSO is affected

Mon, Oct 20, 2025, 07:27 AM

Investigating

We are investigating elevated error rates with Dashboard and API

Mon, Oct 20, 2025, 07:25 AM