Resolved
Some percentage of new credential creates, updates, and deletes errored or were very slow for approx 35 minutes.
Monitoring
We have applied a fix and see recovery.
Investigating
All existing credentials still work and will continue to work.
We are investigating an issue affecting only modifying or creating new ones.