Resolved
The incident has been resolved. Between 12:17 and 12:24 UTC, the dashboard and API were returning 500 errors for postgres database management pages and API endpoints.
Monitoring
For postgres databases, API requests and the dashboard were returning 500 errors. We've deployed a fix.